Author Topic: Podcast Feed Title "The Podcast"  (Read 240 times)

Nick Case

  • Rookie
  • *
  • Posts: 2
Podcast Feed Title "The Podcast"
« on: August 30, 2018, 03:59:36 am »
Hi,

We're having some strange issues related to the feed title of our podcast, essentially, the node:
Code: [Select]
<channel>
<title> {{ title }} </title>

is displaying as:
Code: [Select]
<channel>
<title>The Podcast </title>

Even though we have a Channel Title set which is different.

A bit of digging through the code led me to line 97 of "feed-podcast.php" - which says:

Code: [Select]
<title><?php if( version_compare($GLOBALS['wp_version'], 4.4'<' ) ) { bloginfo_rss('name'); } wp_title_rss(); ?></title>

We are running wordpress 4.9.8, and changing the code to remove the version_compare and just have:
Code: [Select]
bloginfo_rss('name');
works perfectly.

I've searched high and low in Wordpress settings and trawling through the database for a setting which is just "The Podcast" but I can't find it!

Am I missing something?


Shawn Thorpe

  • Administrator
  • Hero Member
  • *****
  • Posts: 2060
Re: Podcast Feed Title "The Podcast"
« Reply #1 on: August 30, 2018, 12:44:02 pm »
Please post the URL to the feed you need help with so we can take a closer look at what's going on.

Nick Case

  • Rookie
  • *
  • Posts: 2
Re: Podcast Feed Title "The Podcast"
« Reply #2 on: August 30, 2018, 04:30:53 pm »
https://www.codecmoments.com/feed/podcast

Obviously it is now displaying correctly as I made the code edit, but hopefully will give you something to look into  :)

Shawn Thorpe

  • Administrator
  • Hero Member
  • *****
  • Posts: 2060
Re: Podcast Feed Title "The Podcast"
« Reply #3 on: August 30, 2018, 11:24:06 pm »
Had you entered the correct title in the PowerPress >> Settings, Advanced Mode >> Feeds tab?

Are you running the latest versions of PowerPress, core WordPress, your WordPress theme, and all other plugins?

Often times, unexplained issues with things like feed titles are caused by poorly developed WordPress themes. Did you try temporarily switching to one of the default WordPress themes (2011, 2012, etc.) to see if the feed title then displayed properly?