Author Topic: Feed not working in iTunes, etc  (Read 337 times)

Tory Vore

  • Rookie
  • *
  • Posts: 1
Feed not working in iTunes, etc
« on: August 07, 2018, 01:27:45 pm »
I think it may be an enclosure problem, but I can't figure out where the issue is coming from. My feed is validating and there is an episode in the feed, but iTunes is saying there's an issue with the metadata and that there are no episodes in it. Google Play and Spotify cannot find the podcast either, but for some reason stitcher can.

Has anyone else had this issue? Is it the media enclosure? How do I fix it?

My feed: https://elevateexperiences.com/feed/podcast

Shawn Thorpe

  • Administrator
  • Hero Member
  • *****
  • Posts: 2060
Re: Feed not working in iTunes, etc
« Reply #1 on: August 07, 2018, 02:04:53 pm »
Not sure why but the media file URL in your first post looks like this:
https://media.blubrry.com/higher_level/content.blubrry.com/higher_level/Episode1Intro.mp314309929

All of those numbers after .mp3 are almost certainly breaking the URL. Edit the post on your site and remove those numbers after mp3 from the URL and try again.

thomaswmiller

  • Rookie
  • *
  • Posts: 3
Re: Feed not working in iTunes, etc
« Reply #2 on: September 11, 2018, 10:48:09 pm »
I too have noticed a similar issue with my feed. It has been working for over a year, and then stopped. The WordPress RSS is correct, but none of the distributors see it like iTunes, TuneIn, etc.

I've ran it through a few validators and it seems to check out.

The URL: https://fbctroytx.org/feed/podcast

Shawn Thorpe

  • Administrator
  • Hero Member
  • *****
  • Posts: 2060
Re: Feed not working in iTunes, etc
« Reply #3 on: September 12, 2018, 12:27:43 am »
thomaswmiller - I've run your feed thru a couple validators and everything came up fine. Please post a link to a syndication point where the podcast isn't displaying properly so we can take a closer look at what's going on.