Author Topic: Possible issue with Yoast SEO  (Read 604 times)

johnb172

  • Full Member
  • **
  • Posts: 36
Possible issue with Yoast SEO
« on: June 28, 2018, 12:40:31 pm »
With recent changes to how Google is discovering podcast I've been trying to get my podcast feeds to be crawled by Google. Not having a whole lot of luck with this. In the process I have found a possible issue due to Yoast SEO. It seems Yoast sets the X-Robots-Tag header tag to noindex for category based feeds.

Code: [Select]
public function noindex_feed() {

if ( ( is_feed() || is_robots() ) && headers_sent() === false ) {
header( 'X-Robots-Tag: noindex, follow', true );

return true;
}

return false;
}

Since Google now wants to index podcast feeds, I'm wondering if it would be best for Powerpress to have a function to prevent Yoast from setting the robots tag. I have submitted a post on the Wordpress support forums about this issue, but who knows what will come of that.

Shawn Thorpe

  • Administrator
  • Hero Member
  • *****
  • Posts: 2060
Re: Possible issue with Yoast SEO
« Reply #1 on: June 28, 2018, 01:06:48 pm »
I will forward this to the Blubrry dev team so they can take a look at it. In the meantime, please reply to this thread with a link to your post on the WordPress forums so we can follow along there if needed.

angelo

  • CIO, RawVoice
  • Administrator
  • Hero Member
  • *****
  • Posts: 4483
Re: Possible issue with Yoast SEO
« Reply #2 on: June 28, 2018, 01:22:26 pm »
Hello John,

Thanks for the heads up. This is bad as you point out.

Please go to PowerPress Settings > Feeds settings tab, there is an option here you can check to prevent other plugins from adding content to the feeds. Please check this option then clear any caching if you have it to see if it solves the issue. In the mean time, I am digging into Yoast's plugin see if there is something we can do to stop it from adding these tags from within PowerPress.

Thanks,
Angelo

johnb172

  • Full Member
  • **
  • Posts: 36
Re: Possible issue with Yoast SEO
« Reply #3 on: June 28, 2018, 04:10:19 pm »
Thanks guys. Checking the option to prevent other plugins from modifying the feed did work to stop Yoast from adding the noindex header.

Here is the Wordpress forum post I made for Yoast:
https://wordpress.org/support/topic/x-robots-tag-header-preventing-rss-from-being-indexed/

angelo

  • CIO, RawVoice
  • Administrator
  • Hero Member
  • *****
  • Posts: 4483
Re: Possible issue with Yoast SEO
« Reply #4 on: June 28, 2018, 04:20:20 pm »
Cool, I will add a note about the do not let plugins modify feeds option in that thread. In the mean time I am still looking at how we can stop it with PowerPress.

Pastor Ray Greenley

  • Rookie
  • *
  • Posts: 1
Re: Possible issue with Yoast SEO
« Reply #5 on: July 01, 2018, 06:46:07 pm »
Thanks for posting this, I believed you've fixed our problem!

Shawn Thorpe

  • Administrator
  • Hero Member
  • *****
  • Posts: 2060
Re: Possible issue with Yoast SEO
« Reply #6 on: July 03, 2018, 02:51:23 pm »
Pastor Ray - glad to see the information in this thread helped you out!

If you've found the support we've provided here to be of value, please consider leaving a review for PowerPress:
https://wordpress.org/support/plugin/powerpress/reviews/?rate=5#new-post
These reviews help us with future development of the plugin, and we'd really appreciate it!

johnb172

  • Full Member
  • **
  • Posts: 36
Re: Possible issue with Yoast SEO
« Reply #7 on: July 28, 2018, 09:06:45 pm »
So I was using the "Do not allow other plugins to modify podcast feeds." option to prevent Yoast from adding the X-Robots-Tag. This worked when I made this post earlier this month. However I just checked the headers for a feed, and the X-Robots-Tag from Yoast is back. I deactivated Yoast and the X-Robots-Tag went away as expected. But it seems like the option in Powerpress to stop other plugins from modifying feeds no longer works. I tried clearing my cache as well. Is anyone else having this issue now?

Shawn Thorpe

  • Administrator
  • Hero Member
  • *****
  • Posts: 2060
Re: Possible issue with Yoast SEO
« Reply #8 on: July 30, 2018, 01:24:08 pm »
johnb172 - are you using PowerPress 7.3? That's the latest version of PowerPress that was released within the last few weeks.

johnb172

  • Full Member
  • **
  • Posts: 36
Re: Possible issue with Yoast SEO
« Reply #9 on: July 30, 2018, 02:53:41 pm »
Yes I am using 7.3

angelo

  • CIO, RawVoice
  • Administrator
  • Hero Member
  • *****
  • Posts: 4483
Re: Possible issue with Yoast SEO
« Reply #10 on: July 30, 2018, 03:08:32 pm »
Did Yoast change his plugin in recent weeks? Last version I looked at the code, as long as our option was checked they would not be able to modify the headers.

Can you reply with the feed URL in question?

johnb172

  • Full Member
  • **
  • Posts: 36
Re: Possible issue with Yoast SEO
« Reply #11 on: July 30, 2018, 03:13:21 pm »
Did Yoast change his plugin in recent weeks? Last version I looked at the code, as long as our option was checked they would not be able to modify the headers.

Can you reply with the feed URL in question?

Feed URL: https://gfqnetwork.com/shows/this-week-in-radio-tech-2/feed/

I believe Yoast has had a few updates in the last month. Though nothing in the release notes ever said anything about RSS feeds.
« Last Edit: July 30, 2018, 03:17:36 pm by johnb172 »

angelo

  • CIO, RawVoice
  • Administrator
  • Hero Member
  • *****
  • Posts: 4483
Re: Possible issue with Yoast SEO
« Reply #12 on: July 31, 2018, 01:55:27 pm »
Oh I see the problem. https://gfqnetwork.com/shows/this-week-in-radio-tech-2/feed/ is a category feed, PowerPress doesn't stop other plugins from modifying regular WordPress category feeds. Your podcast only feeds should not have the X-Robots-Tag, but that does not help you at the moment.

Short term fix is to disable the code in Yoast's plugin. I still have this on my TODO, it may take a separate plugin to fix, rather than add something to PowerPress. I've analyzed Yoasts' plugin it does not make sense to set the X-Robots-Tag for RSS in the first place. The ticket with Yoast's plugin is here: https://github.com/Yoast/wordpress-seo/issues/10262

Thanks,
Angelo