Author Topic: Blog and category search view only showing mp3 link  (Read 765 times)

Richard

  • Rookie
  • *
  • Posts: 3
Blog and category search view only showing mp3 link
« on: July 26, 2015, 07:27:24 pm »
New here, getting a little frustrated and confused with blubrry, would be grateful for some help.

I am setting up a site for a client. Trying to get the functionality sorted before making it look pretty and am transfering everything over from their old site to this new one.

They have a ton of mp3 podcasts, and what I am doing is setting up a blog post for each podcast. Within the posts themselves, the player is coming up as I want it to.

However, on the blog page and category page, all I am getting is a link to where the mp3 is, and not the player. See the top and bottom 2 of this page to show what is happening.

http://1st-impression-design.com/malaga/category/podcast/

My question is, how do I get it to display the player on these pages? I've gone through the "fix it" solutions on the plugin, I have also deactivated all my plugins to see if there's any conflict. Nothing seems to clear this problem.

Any advice gratefully received.
 

Shawn Thorpe

  • Administrator
  • Hero Member
  • *****
  • Posts: 2060
Re: Blog and category search view only showing mp3 link
« Reply #1 on: July 26, 2015, 10:16:29 pm »
It looks like the theme is set to display headlines only, or post titles, on archive pages. There's nothing in PowerPress that should cause a problem like this to happen. If the theme has display settings, check there. Otherwise, take a look at the code for archive pages (possibly the archive.php file) and see if anything unusual is showing up there.

Richard

  • Rookie
  • *
  • Posts: 3
Re: Blog and category search view only showing mp3 link
« Reply #2 on: July 27, 2015, 07:04:03 am »
Thanks for that. At least it means I can stop looking at blubrry for the cause.

The only way I can get the player to show up on the search pages is by setting the blog post to audio format, but then the default player shows up, and not the blubrry one.

Right now, the mp3 file is linked under the blubrry settings down the blog post via the url. I don't know if that has any impact.

Richard

  • Rookie
  • *
  • Posts: 3
Re: Blog and category search view only showing mp3 link
« Reply #3 on: July 27, 2015, 07:46:45 am »
SOLVED.

In my theme (Divi by Elegant Themes) there was a switch to turn excerpts on. That did the trick.

Thanks again for the guidance :)

Shawn Thorpe

  • Administrator
  • Hero Member
  • *****
  • Posts: 2060
Re: Blog and category search view only showing mp3 link
« Reply #4 on: July 27, 2015, 02:03:14 pm »
Excellent! Thanks for following up with the exact solution. This will help other users in the future who come to the forum.