Author Topic: Weird long link issue on Wordpress site blog posts.  (Read 863 times)

Angela

  • Full Member
  • **
  • Posts: 12
Weird long link issue on Wordpress site blog posts.
« on: May 12, 2015, 04:53:48 pm »
Hi,

I'm not sure how to explain this exactly, so I'll do my best. I am also including a screen grab to show what I'm asking about.

I'm using WordPress 4.2.2 running Impreza theme and PowerPress plugin version 6.0.3. I'm also using blubrry.com for hosting all my podcasts.

When I create a new post I'm using the "Link to Media hosted on Blubrry.com" blue button to upload the podcast episode and add it to my post.

Here's my issue:

When going to the "Blog" page where it lists summaries of each post in a list, the URLs for my podcasts are really long and cover the right column... this is really just an aesthetic issue as everything functions as it should. However, it is rather unsightly and I'd like to get it corrected if possible. I think these are the links that "create" the embedded Blubrry/PowerPress podcast player.

Here is the page I'm referring to: http://transpersonalradio.com/shows

Here is the screen grab: https://app.box.com/s/oa9ujs6rh9vas77eynsa27rfltvhnhvj

When looking at each individual post, everything looks great, aligned properly, etc.

If you think this is a theme issue, please let me know and I'll contact them as well.

Thank you!

~ Angela

vegetarianzen

  • Rookie
  • *
  • Posts: 3
Re: Weird long link issue on Wordpress site blog posts.
« Reply #1 on: May 15, 2015, 02:06:37 pm »
Yes!! I've been having the same issue!  The long link shows up below the player on the show notes excerpts on my homepage.  On the show notes page itself, the player is fine (no long link underneath).

Here's a screenshot: http://www.screencast.com/t/JplgTW2u9O
Our website is http://www.vegetarianzen.com

I have tried everything I can think of to remove it, with no luck.  I'd love to see someone from Blubrry address this question.  Thanks!

Larissa

mgdell

  • Blubrry Customer Support Coordinator
  • Administrator
  • Hero Member
  • *****
  • Posts: 3318
Re: Weird long link issue on Wordpress site blog posts.
« Reply #2 on: May 16, 2015, 11:25:57 am »
In your powerpress settings > Media Appearance tab (in advanced mode) uncheck where it says " Display media / links in: WordPress Excerpts (e.g. search results)" and save settings.

-Mike

vegetarianzen

  • Rookie
  • *
  • Posts: 3
Re: Weird long link issue on Wordpress site blog posts.
« Reply #3 on: May 16, 2015, 11:57:59 am »
Thanks, Mike.  I tried that, but the long link on my homepage excerpts is still there.

Screenshot:  http://screencast.com/t/ljxF61dsEdd

Is there something else I can try? 

Larissa

vegetarianzen

  • Rookie
  • *
  • Posts: 3
Re: Weird long link issue on Wordpress site blog posts.
« Reply #4 on: May 16, 2015, 12:31:46 pm »
I've been messing with it a bit, and I did get the link to go away (although I had to remove the player from the homepage post excerpts too, but that's okay).

On the Media Appearance tab, I changed the Display Media & Links option from "Above Page Content" to "Disable".  This removed the long media link from the homepage excerpts, but it also removed the all the media players from my posts. 

I added the [powerpress] shortcode at the beginning of the text on our most recent show notes post, and the player works fine there.  I'm okay with not having the player on the homepage excerpts, because I want people to visit the post anyway. :)

http://screencast.com/t/78A9R6jl

Hope this helps you, Angela.

Larissa

Angela

  • Full Member
  • **
  • Posts: 12
Re: Weird long link issue on Wordpress site blog posts.
« Reply #5 on: May 21, 2015, 08:02:43 pm »
In your powerpress settings > Media Appearance tab (in advanced mode) uncheck where it says " Display media / links in: WordPress Excerpts (e.g. search results)" and save settings.

-Mike

Hi there Mike,

Just an FYI, this particular setting was already unchecked, so that wasn't the issue for me.

Larissa,

THANK YOU!!!! I followed your post and it worked like a charm. And thank you for the helpful screen grab. Very nice.

The weird long links are now gone. And adding [powerpress] to the post itself seems to work just fine.

Unfortunately, I'll have to go through and add that manually to each and every post... whew! Better get started!

Hopefully this weird glitch can be addressed for future releases of PowerPress. It's an amazing plugin!

Thanks again!

~ Angela