Author Topic: No files listed in the feed  (Read 3214 times)

skeemer

  • Newbie
  • Posts: 4
No files listed in the feed
« on: March 16, 2009, 05:34:47 pm »
I'm using Powerpress w/ WP Audio Player 2.0 beta and most stuff seems to be working fine. The posts work fine and the audio player change was easy. What's not happening is any mention of the mp3 files in the podcast feed.

Is there anything I should check? I can't seem to find any preference that would create this problem.

angelo

  • CIO, RawVoice
  • Administrator
  • Hero Member
  • *****
  • Posts: 4483
Re: No files listed in the feed
« Reply #1 on: March 17, 2009, 12:05:44 am »
If you have the latest version of PowerPress, make sure you're in advanced mode, then go to the first option "Enhance Feeds" under Feed Settings. Make sure "Enhance All Feeds" or "Enhance Main Feed" is selected. Otherwise your podcasts will not appear in your main feed.

So we can take a look, what is the link to your web site?

skeemer

  • Newbie
  • Posts: 4
Re: No files listed in the feed
« Reply #2 on: March 17, 2009, 04:07:25 pm »
The problem is that it is the podcast only feed that doesn't have any links. So, I don't think enhance feeds option will make a difference.

http://slopastor.leolutz.com/feed/podcast/

angelo

  • CIO, RawVoice
  • Administrator
  • Hero Member
  • *****
  • Posts: 4483
Re: No files listed in the feed
« Reply #3 on: March 17, 2009, 04:34:35 pm »
You don't appear to be using PowerPress. I just took a look at the feeds source and did not find the PowerPress comment line.

PowerPress will disable itself if it detects one of the other Podcasting plugins for WordPress enabled. It may be that you still have PodPress or some other plugin enabled. Go to the PowerPress settings page and see if there is a warning highlighted in yellow at the top of the page indicating as such.

skeemer

  • Newbie
  • Posts: 4
Re: No files listed in the feed
« Reply #4 on: March 17, 2009, 05:59:36 pm »
There was that warning when I initially installed PowerPress. I got rid of the other and reactivated it. Just now I even tried deleting the PowerPress plugin and reinstalling. It still doesn't seem to have any affect. I set it to enhance all feeds and that made no difference on any feed as well.

I noticed that after removing and install the plugin again, the settings were still there. Do I need to remove the settings from the wp_options table to get this working?

angelo

  • CIO, RawVoice
  • Administrator
  • Hero Member
  • *****
  • Posts: 4483
Re: No files listed in the feed
« Reply #5 on: March 17, 2009, 08:13:24 pm »
Your feed looks great now: http://slopastor.leolutz.com/feed/podcast/ You may want to clear your browser cache then refresh your feed to see the media enclosures.

I just subscribed to your feed in iTunes and it is pulling down the episodes ok. You're good to go.

skeemer

  • Newbie
  • Posts: 4
Re: No files listed in the feed
« Reply #6 on: March 17, 2009, 09:48:02 pm »
Sure enough. Played a bit more with it.
When I set "Do Not Enhance Feeds" then neither the main feed or podcast feed have the mp3s. When I set "Enhance Main Feed Only" then the podcast feed has the mp3's but not the main feed. The "Enhance All" does just that. I'm not sure if that's a bug or what, but thought that was odd based on the descriptions.

Thanks for the help!
cheers!
Leo

angelo

  • CIO, RawVoice
  • Administrator
  • Hero Member
  • *****
  • Posts: 4483
Re: No files listed in the feed
« Reply #7 on: March 18, 2009, 10:27:49 am »
There may be a bug, the podcast feeds are still supposed to have the media added to them. I'm taking a closer look now to see if something is broken.