Author Topic: Podcast Not Playing  (Read 3492 times)

breakthru-mentor

  • Newbie
  • Posts: 4
Podcast Not Playing
« on: January 06, 2009, 01:39:35 am »
Hi

I'm new to Wordpress and Podcasting. I've just put the Powerpress plugin to my site and am having trouble getting the podcast to play. The site is www.alignleadinspire.com

I'm using amazons3 to store the mp3 file. I don't know if that could be the problem or not. If anyone could help me I'd really appreciate it.

I'll let you know in advance I'm no techno whizz. :-[

Thanks
Shelley

Rob Safuto

  • Full Member
  • **
  • Posts: 13
Re: Podcast Not Playing
« Reply #1 on: January 06, 2009, 07:38:21 am »
It appears to be something related to the way you have linked to the mp3 file.

This is the link you have now.

http://www.alignleadinspire.com/https://membershipsite.s3.amazonaws.com/audio/barbaraannis.mp3

I believe that the link you want is.

https://membershipsite.s3.amazonaws.com/audio/barbaraannis.mp3

Check your settings.

breakthru-mentor

  • Newbie
  • Posts: 4
Re: Podcast Not Playing
« Reply #2 on: January 06, 2009, 06:29:27 pm »
Thanks Rob for the reply. Do you have any idea where I change that, as I don't know how it could have got my website name in front of the amazon link (which is where the media file is).

What I did was to

1. Under settings Powerpress - default media - I left this blank
2. I put the Amazon S3 link in the actual post under Podcast Episode.

So there's obviously something else I need to change, if you have any ideas on what I need to do, I'd appreciate it. Thanks again for helping me.

Shelley

angelo

  • CIO, RawVoice
  • Administrator
  • Hero Member
  • *****
  • Posts: 4483
Re: Podcast Not Playing
« Reply #3 on: January 06, 2009, 11:05:19 pm »
If the Media URL is blank in the settings, then the only place you need to edit the URL from is in the Podcast section where you edit your blog post. When expanded, there will be a checkbox that you need to check to modify the podcast episode. Once you check this, you will see the Media URL. This is where you need to remove the first URL http://www.alignleadinspire.com/. Just in case, double check you're using the correct URL by copying and pasting the URL into a new window and hit enter. If you start to play/download your media, then you know that's the URL you want to use.

--angelo

breakthru-mentor

  • Newbie
  • Posts: 4
Re: Podcast Not Playing
« Reply #4 on: January 06, 2009, 11:27:19 pm »
Hi Angelo

Thanks for the reply. It's still not working for me though.

I have deleted the original post and put up a new one and yet still the player doesn't play.

The expanded podcast section in my blog post definitely only has the url: 

https://membershipsite.s3.amazonaws.com/audio/Taming-The-Email-Beast-Interview.mp3

in it.  I definitely do have the media url blank in the Settings area.

As suggested, I checked the link by copying and pasting the url into a new page and it works fine.

Do you have any other suggestions?

Thanks
Shelley

angelo

  • CIO, RawVoice
  • Administrator
  • Hero Member
  • *****
  • Posts: 4483
Re: Podcast Not Playing
« Reply #5 on: January 07, 2009, 01:53:21 am »
I just copied/pasted the URL into my development environment and discovered the issue is with the https:// portion of the URL. The plugin currently does not support https:// as a protocol for the media urls. The simple fix would be to use the http:// insecure url instead, e.g. http://membershipsite.s3.amazonaws.com/audio/barbaraannis.mp3.

There's really no reason to serve your media through HTTPS (secure HTTP). Since the data can be downloaded by anyone, it should not matter if it is encrypted during download. On the other hand, it may be best not to use HTTPS since some applications that do not have SSL support (such as Juice) will not be able to download the media. Basically, don't use https:// if you want your content to be accessible by most all podcatching applications.

I've added https support to the feature TODO list even though in your case it is not necessary. Someone may find the need to serve password protected content that is served securely.

breakthru-mentor

  • Newbie
  • Posts: 4
Re: Podcast Not Playing
« Reply #6 on: January 07, 2009, 05:22:54 am »
Thanks Angelo. I was just following the protocol for the url that Amazon S3 gives.

Works great now. Thanks again for all your help. I really do appreciate it.

Warmest wishes
Shelley