Author Topic: Image not updating from Default in feed for Category Podcasting  (Read 1358 times)

angelo

  • Custom Title
  • Administrator
  • Hero Member
  • *****
  • Posts: 4029
  • CIO, RawVoice
    • Angelo's Blog
Re: Image not updating from Default in feed for Category Podcasting
« Reply #15 on: August 23, 2013, 02:24:25 am »
Ok., no problem.

andrealeo

  • Newbie
  • *
  • Posts: 13
Re: Image not updating from Default in feed for Category Podcasting
« Reply #16 on: August 27, 2013, 06:16:02 pm »
Very very odd, the 5.0 upgrade did not solve the issue, had to once again swap the powerpress itunes_default and rss_default images to my own in order to maintain orderly appearance on iTunes, but if I change the image on the category podcasting the change doesn't apply to the feeds...

Andrea

angelo

  • Custom Title
  • Administrator
  • Hero Member
  • *****
  • Posts: 4029
  • CIO, RawVoice
    • Angelo's Blog
Re: Image not updating from Default in feed for Category Podcasting
« Reply #17 on: August 27, 2013, 08:00:48 pm »
OK I will need more specifics to try to duplicate the issue. How doe you create the category? What version of WordPress are you using? Does disabling all other plugins help ? What other plugins are You using?
 

angelo

  • Custom Title
  • Administrator
  • Hero Member
  • *****
  • Posts: 4029
  • CIO, RawVoice
    • Angelo's Blog
Re: Image not updating from Default in feed for Category Podcasting
« Reply #18 on: September 05, 2013, 10:28:06 am »
Are you still having an issue? If so please answer my questions so I can investigate.

alpha262

  • Newbie
  • *
  • Posts: 1
Re: Image not updating from Default in feed for Category Podcasting
« Reply #19 on: February 03, 2014, 04:12:21 pm »
I am having essentially the same issue.  I can change channel settings all day long, but certain tags just will not update.  The one that jumps out most is the artwork, although the title is also not updating.  No matter what I do, the RSS keeps saying the same thing.  Here's an example:

<image>
<title>Henceforth Media, LLCHenceforth Media, LLC | Henceforth Media, LLC</title>
<url>http://henceforthmedia.com/wp-content/plugins/powerpress/rss_default.jpg</url>
<link>http://henceforthmedia.com</link>
</image>

Here's the URL to the RSS feed I'm talking about:
http://henceforthmedia.com/feed/popular-crackpot/

Help!  (And thank you!)

angelo

  • Custom Title
  • Administrator
  • Hero Member
  • *****
  • Posts: 4029
  • CIO, RawVoice
    • Angelo's Blog
Re: Image not updating from Default in feed for Category Podcasting
« Reply #20 on: February 04, 2014, 08:00:40 am »
Do you have any caching plugins? Can you reply with URLs to your feeds?

andrealeo

  • Newbie
  • *
  • Posts: 13
Re: Image not updating from Default in feed for Category Podcasting
« Reply #21 on: March 27, 2014, 09:30:57 am »
Hi, chiming into the conversation as I still have the same problems for my feeds as listed previously in this post, the artwork still doesn't update and is defaulted to rss_default and itunes_default for all my category feeds. Do you have a list of incompatible plugins that could be causing this problem.
Thanks!

Andrea

angelo

  • Custom Title
  • Administrator
  • Hero Member
  • *****
  • Posts: 4029
  • CIO, RawVoice
    • Angelo's Blog
Re: Image not updating from Default in feed for Category Podcasting
« Reply #22 on: March 27, 2014, 11:51:38 am »
Unfortunately most folks are hesitant on the forums to say what screwed up their site. I do know that the caching plugins usually cause a lot of the problems because the folks using them don't know to clear them anytime they make a plugin or theme change.

We wrote a page how to diagnose problems on your own. Here's the link: http://create.blubrry.com/resources/powerpress/using-powerpress/diagnosing-feed-andor-player-issues-with-powerpress/

If the problem is with your feed specifically, you may want to make sure you have category podcasting enabled and that you've added the category podcast settings to that category. Categories are a function of WordPress, PowerPress simply adds iTunes attributes to those feeds.

andrealeo

  • Newbie
  • *
  • Posts: 13
Re: Image not updating from Default in feed for Category Podcasting
« Reply #23 on: March 28, 2014, 06:00:10 am »
Hi Angelo, thanks for the email, it's a difficult one as my problem is not that iTunes is not reading the feed correctly, but that the feed itself is wrong.

I just set up another podcast via category podcasting (enabled and with enabled blubrry support) and when I go to the Feed Validator I see that the feed is pointing at itunes_default and rss_default jpegs instead of the ones that I've set up on the category podcasting page which is a different image.  Could that still be related to caching (I've cleared my cache with WpEngine just in case) or with something else? I'm using Ultimate Category Excluder to make sure the right posts go to the right categories and not to the main feed...
 
<channel>
<title>Digital Music Trends &#187; Events</title>
<atom:link href="http://digitalmusictrends.com/category/events/feed/" rel="self" type="application/rss+xml" />
<link>http://digitalmusictrends.com</link>
<description>Weekly podcasts on the latest news in the digital music industry</description>
<lastBuildDate>Fri, 28 Mar 2014 10:51:26 +0000</lastBuildDate>
<language>en-US</language>
<sy:updatePeriod>hourly</sy:updatePeriod>
<sy:updateFrequency>1</sy:updateFrequency>
<generator>http://wordpress.org/?v=3.8.1</generator>
<!-- podcast_generator="Blubrry PowerPress/5.0.5" mode="advanced" -->
<itunes:summary>Weekly podcasts on the latest news in the digital music industry</itunes:summary>
<itunes:author>Digital Music Trends</itunes:author>
<itunes:explicit>no</itunes:explicit>
<itunes:image href="http://digitalmusictrends.com/wp-content/plugins/powerpress/itunes_default.jpg" />
<itunes:subtitle>Weekly podcasts on the latest news in the digital music industry</itunes:subtitle>
<image>
<title>Digital Music Trends &#187; Events</title>
<url>http://digitalmusictrends.com/wp-content/plugins/powerpress/rss_default.jpg</url>
<link>http://digitalmusictrends.com/category/events/</link>
</image>

andrealeo

  • Newbie
  • *
  • Posts: 13
Re: Image not updating from Default in feed for Category Podcasting
« Reply #24 on: March 28, 2014, 06:32:21 am »
Further update, I've now created a staging site on WPEngine (which means all caching is disabled) and have tested disabling all plugins, deleting Blubrry and re-installing it, deleting feeds and re-adding them and nothing seems to work. Any more ideas?
Thanks,
Andrea

angelo

  • Custom Title
  • Administrator
  • Hero Member
  • *****
  • Posts: 4029
  • CIO, RawVoice
    • Angelo's Blog
Re: Image not updating from Default in feed for Category Podcasting
« Reply #25 on: March 28, 2014, 08:58:41 am »
Try a different theme. It is completely possible that your theme is overriding the images.

Also please confirm you are going to PowerPress > Category podcasting settings, selecting the category, adding podcasting then saving these settings (this adds podcasting to the category) Then re-edit the category podcasting settings, go to the "Artwork" tab, and upload your iTunes image there. Correct?

Lets also try setting the image for the main podcast feed, you go to PowerPRess Settings > Artwork tab and upload there. main podcast feed: http://digitalmusictrends.com/feed/podcast/

andrealeo

  • Newbie
  • *
  • Posts: 13
Re: Image not updating from Default in feed for Category Podcasting
« Reply #26 on: March 28, 2014, 10:12:23 am »
Hi Angelo, can't believe it was the theme that was creating all the trouble, it looks like Cyberchimps' Ifeature pro is incompatible, as soon as I changed back to the default theme it all works fine, but I also found that another premium plugin I had here called Social Play was incompatible. 

If I can't resolve the Cyber Chimp issue I am more than happy to change the theme of my website to make the feeds work properly, but I wanted to ask you do you know of good responsive premium themes for WordPress that are compatible with Powerpress in full?

Thanks

Andrea

angelo

  • Custom Title
  • Administrator
  • Hero Member
  • *****
  • Posts: 4029
  • CIO, RawVoice
    • Angelo's Blog
Re: Image not updating from Default in feed for Category Podcasting
« Reply #27 on: March 28, 2014, 11:12:11 am »
I personally do not recommend the use of premium themes, or theme systems for that matter. They "lock" you into their theme by adding proprietary features that you will loose when you do decide to switch to another theme.

We recently helped a client with the "Blocked" theme, it is $45. I was impressed with how easy it was to line up blocks of data on the home page and it is responsive which is important.

The Blubrry Create site (http://create.blubrry.com/ is a theme we made in-house derived from the twentythirteen theme. Just an example where you can take a good theme and make it what you want without having to be stuck with a specific theme company.