Author Topic: Can not embed anything  (Read 965 times)

blazman

  • Newbie
  • Posts: 2
Can not embed anything
« on: September 17, 2012, 04:12:11 pm »
I am trying to embed some code and is just doesn't show up. I look at the HTML that is generated and it is just like it is completely omitted.

That is what the post looks like

when I go to the published post there is just the text.
http://cultureoffit.com/podcast/episode-1-erik-and-jerry-decide-to-get-in-shape-and-do-a-tough-mudder-2/

Todd

  • Administrator
  • Sr. Member
  • *****
  • Posts: 418
Re: Can not embed anything
« Reply #1 on: September 17, 2012, 11:30:14 pm »
Try embedding a YouTube video. I dont think that is a legal embed aka using an iframe, Angelo will weigh in but I don't think that will work. You do know that the HTML5 player we have works on all devices.

angelo

  • CIO, RawVoice
  • Administrator
  • Hero Member
  • *****
  • Posts: 4483
Re: Can not embed anything
« Reply #2 on: September 18, 2012, 09:39:53 am »
The latest embeds from YouTube and most other sharing sites are iframe based.

Usually over zealous theme developers apply styling to iframes, embed and object tags. It may be that your theme is overriding the_content /the_excerpt filter as well. \ Try switching to the default WordPress twentyeleven twentytwelve theme and see if the embed appears. Then you'll know if it's a theme issue or not.

blazman

  • Newbie
  • Posts: 2
Re: Can not embed anything
« Reply #3 on: September 18, 2012, 04:05:11 pm »
I tried a youtube embed and that uses iframes as well and no it does not appear. I also tried changing the theme and that did not work. I tried using the blubrry player and that does not show up either. SOOOOO I went to the settings in PowerPress  under media appearance be sure that Enable PowerPress Media Players and Links is clicked.  Then everything works fine.. I hope this helps someone else.

-Erik

angelo

  • CIO, RawVoice
  • Administrator
  • Hero Member
  • *****
  • Posts: 4483
Re: Can not embed anything
« Reply #4 on: September 18, 2012, 05:45:24 pm »
Ahh, yes if you go into PowerPress Settings > Appearance and turn off the player and links, then no media, embed or PowerPress created, will be displayed in your blog posts.