Author Topic: podcast slug am i missing something  (Read 2030 times)


  • Full Member
  • **
  • Posts: 20
podcast slug am i missing something
« on: April 20, 2012, 09:30:38 am »
Hey guys please bear with me as i may be missing something very simple..

I am trying to create a page called 'Podcast' where i want my shows to be... essentially this is the blog index page.

When i create the page the url is amended to

even though i go into settings and make the new page my posts page

I have changed the settings inside the plugin to map to the new page, but i still cannot achieve what im trying to achieve...

lol hair pulling, but all i want is the show to be sat on the ur of choice which would say /podcast   NOT /podcast-2    anybody help?



  • CIO, RawVoice
  • Administrator
  • Hero Member
  • *****
  • Posts: 4483
Re: podcast slug am i missing something
« Reply #1 on: April 20, 2012, 02:53:48 pm »
WordPress adds URL friendly text labels to the web address's, they are called 'slug' names. These slug names make up the . PowerPress adds the slug name 'podcast' for your podcast only feed. Just as WordPress adds 'feed', 'atom', and 'rss' as slug names for those respective feeds. So every time you try to add something else with the same 'slug' name, WordPress will add something to it so it is unique and does not conflict with the 'podcast' slug name already added by PowerPress. You can confirm this by trying to add a page with the slug name 'feed' or 'rss', WordPress will automatically rewrite it as feed-1 for example.

Because of the complexity of adding podcast support, we currently do not have a work around for this. You will have to name your page something other than 'podcast' if you want to use our plugin.

If you are having this problem with existing static pages or category with the name 'podcast', there is an option in PowerPress that may fix the problem. Go to PowerPress Settings > Basic Settings tab, and near the bottom for option labeled 'Podcast Permalinks" select 'Match Feed Name to Page/Category'. Keep in mind that this is not default WordPress behavior and we cannot guarantee that this will solve your problem.